BI

Ξ 97 comentários

Excel: Você sabe usar a função “SE”?

publicado por Gilberto Gomes

duvidaA função SE é, na minha opinião, uma das funções mais importantes do Excel. É ela que permite ao usuário estabelecer condições e, com isso, definir caminhos diferentes em seus cálculos.

Exemplificando, podemos ter em uma célula o valor do salário e em outra o valor do imposto de renda, que será calculado APENAS SE o salário for superior a um piso qualquer.

Eu sempre recomendo que, quando uma fórmula precisar seguir “DETERMINADAS CONDIÇÕES“, ela seja, primeiramente, DESENHADA NO PAPEL, isso mesmo, NO PAPEL, À MÃO! Com o tempo ganhamos experiência e podemos pular essa etapa. O correto planejamento desse tipo de fórmula garante seu sucesso.

Tentarei explicar, da uma forma bastante simplificada e direta, o raciocínio básico da construção de uma fórmula usando a função SE.

Projetando no Excel a fórmula que terá a função SE

Sempre que temos DUAS opções, precisamos tomar UMA decisão. Se estamos seguindo por uma estrada e encontramos uma bifurcação, temos que escolher um dos caminhos. Alguma característica (ou conjunto delas) determinará a nossa decisão.

Então, trazendo para o nosso modelo, a função SE é estruturada pela presença de TRÊS argumentos, e pode ser representada pelo seguinte modelo:

=SE(TESTE_LOGICO; CAMINHO A; CAMINHO B) ou exemplificando:

=SE(IDADE<18; “MENOR”; “MAIOR”)

Fazendo-se a leitura estruturada da sintaxe acima, temos:

SE IDADE MENOR QUE 18 ENTÃO

MENOR

SENÃO

MAIOR

FIM

Observe que temos duas opções de resposta para o problema: MENOR ou MAIOR. Como eu disse agora há pouco, se tenho que escolher entre DUAS hipóteses, basta fazer UM teste. Essa regra se aplica a amostras maiores: se tenho 5 hipóteses, resolverei com 4 testes. Sempre teremos UM teste a menos que o número de hipóteses. Essa é a regra geral.

Então, criemos agora um exemplo prático do uso da função SE.

No modelo abaixo temos uma ficha, bastante simplificada, para calcular o líquido a receber de um funcionário.

MODELO_BASE

Prestem utilizaremos aqui três desses campos:

  • SALÁRIO (será digitado pelo usuário)
  • VALE REFEIÇÃO (valor fixo de 200 reais SE O SALÁRIO FOR SUPERIOR A R$ 5.000,00)
  • LÍQUIDO A RECEBER: SALÁRIO – VALE REFEIÇÃO.

Nesse caso temos duas opções: COBRAR R$200,00 ou COBRAR ZERO. A decisão dependerá do valor do salário.

Desenhamos abaixo o nosso problema e traduzimos para a fórmula final:

ARVORE1

Portanto, basta inserirmos a fórmula =SE(I5>5000;200;0) na célula I7 para calcularmos o desconto de VALE REFEIÇÃO.

ESCREVENDO_SE_1

Pronto. Conforme podemos ver na ilustração abaixo, temos o desconto de R$ 200,00 referentes ao vale refeição condicionado ao salário. Alterem o valor do salário para algo inferior a R$ 5.000,00 e vejam que não haverá desconto de vale refeição.

MODELO_FINAL

 

Espero que curtam esse artigo e, acreditem, esse conhecimento poderá trazer muitos frutos.
Para fazer o download do modelo utilizado, CLIQUE AQUI.

Estou aqui, à disposição, aceitando sugestões para novos artigos.

Artigos Relacionados

Autor

Administrador de empresas e analista de sistemas, 25 anos de experiência em consultoria, treinamentos e palestras, Microsoft Certified Trainer ID# 11905, especialista em Office, atuando ativamente em consultorias de automação. Palestrante em mais de 50 eventos apresentados, demonstrando os produtos Office em Universidades (UFMG, FUMEC, Faculdade de Ciências Médicas) e em grandes empresas (Usiminas, Açominas, BEMGE, Itambé, AMBEV); Prefeituras e outros Órgãos Públicos. ( www.excelline.net )

Gilberto Gomes

Comentários

97 Comments

  • Eu já conhecia a função, mas mesmo assim o exemplo foi muito bacana.

  • Bom dia,
    Alguém poderia me dizer como faço na função se para que se a condição for verdadeira ou falsa ela atribua o valor de determinada célula.
    Ex; se(a1=a7;”=b12″;=c12″)

    Caso eu esteja utilizando a função errada me ajudem nisso também.

    • Bom dia Jorge,

      não sei ao certo qual seria seu objetivo final, mas, creio que basta alterar sua fórmula para a que coloco abaixo:

      se (a1=a7;b12;c12)

      À disposição,

      Gilberto Gomes

    • usa o endereço da celula sem o simbolo de igualdade
      se(a1=a7;b12;c12

  • tenho a seguinte planilha abaixo. Gostaria de um fórmula que na 5a. coluna, aparecesse a FRQ ANGAR de cada número. não estou conseguindo. O UBERABA, aparece em todas as linhas da 5a. coluna. Podem me ajudar.

    obrigado,

    ref FRQ ANGAR REF FRQ ANGAR
    12456 1 UBERABA 12456 UBERABA
    12456 1 UBERABA 13457 BOQUEIRÃO
    12456 1 UBERABA 26347 ALTO DA XV
    13457 1 BOQUEIRÃO
    13457 1 BOQUEIRÃO
    13457 1 BOQUEIRÃO
    13457 1 BOQUEIRÃO
    13457 1 BOQUEIRÃO
    26347 1 ALTO XV
    26347 1 ALTO XV
    26347 1 ALTO XV
    26347 1 ALTO XV
    26347 1 ALTO XV

    • Olá Carlos,

      Pelo que colocou não dá para interpretar o que vc quer, consegue enviar o arquivo e exemplificar?

      abs

      Paulo R Lopes

  • Obrigado,
    consegui resolver usando o PROCV.

  • Gostei do exemplo, mas preciso fazer uma fórmula com datas.

    Data de criação do chamado X Data de Realização

    Se a criação for menor que a realização = OK
    Se a criação for maior que a realização = VER
    Será que consegue me ajudar?
    Obrigada!!

    • Olá, assumindo que A2 é a Criação e B2 a Realização:
      =SE(B2=””;”VER”;SE(B2<A2;"VER";"OK"))

      Obs1: Está tratando também quando não existir data de realização, neste caso irá imprimir VER
      Obs2: QUando a data de criação é igual à de realização está imprimindo OK, caso deseje que imprima VER basta incluir o sinal de igual após o sinal de menor, ficando assim:
      =SE(B2="";"VER";SE(B2<=A2;"VER";"OK"))

  • Gosite muito, mas resolvi um problema, agora gostaria de saber se pode em ajudar com outro:

    Preciso de uma fórmula onde seria mais ou menos assim:
    Quando a célula X for >=16 e=35 e=51 e65 multiplicar 0,

    Teria como me ajudar?

  • Gostaria que alguém me ajudasse como fazer uma condição dupla.
    Exemplo:
    Se a célula L15 é maior que um e a célula f2 é igual a 2, então o resultado é igual L15, senão é igual a zero.
    Alguém poderia me ajudar?

    • Tente colocar a seguinte fórmula:
      =(SE(E(L15>1;F2=2);L15;0))

    • Moacir, tente usar esta fórmula:
      =(SE(E(L15>1;F2=2);L15;0))

  • Bom dia!!!

    Tenho uma lista de códigos na coluna A, das células A1 até a A5, os códigos são: 5185-1, 5185-2, 5339-0, 5355-0, 5401-0 respectivamente. Na célula B1 preciso realizar o teste lógico que se o valor digitado em B1 for = a um dos códigos citados da coluna A ele retornará o valor GRAVE, caso o valor digitado não seja localizado nesta lista ele retornará o valor, CORRIJA O CAMPO.

    Já tentei fazer usando a Função SE e não consegui, alguém pode me ajudar por favor???

    Um grande abraço e obrigado antecipadamente.

    • Sr. Eduardo.

      encaminho para o seu email um xls com duas formas de resolver sua questão: a primeira com validação de dados e a segunda com o SE + PROCV.

      À disposição,

      Gilberto

  • Tenho uma planilha com um banco de dado de clientes sendo que existem três tipos de códigos, CNPJ (14 caracteres); CPF (11 caracteres) E ASSOCIADOS (até 9 caracteres). Quero realizar um filtro em outras planilhas separando os três segmentos para realizar análises separadas. Na primeira planilha (CNPJ) iniciei a lógica mas não consigo terminar. =SE(NÚM.CARACT(GERAL!A2)=14;COPIAR VALOR DA LINHA; PULAR PARA PRÓXIMA LINHA QUE CONTENHA CNPJ.

    Não sei bem se seria isso ou se tem alguma maneira mais facil…..

    • Boa tarde Igor,

      tenho aqui uma ideia que, creio, assemelha-se ao que você precisa. Por gentileza, informe-se seu email para que eu possa enviá-la.

      Gilberto
      ggomesbrazil@yahoo.com

  • Segue email

  • Bom dia,
    estou com o seguinte problema, tenho uma tabela com valores em que na coluna 3 tenho as opções: aprovado, finalizado e em andamento, na coluna 2 preciso que o preenchimento seja automático com a resposta “SIM” se eu colocar na coluna 3 aprovado ou finalizado e que a resposta seja “NÃO” se o que estiver na coluna 3 for em andamento.
    estou tentando utilizar a função SE, mas acho que está errado.
    poderia me ajudar com essa questão?

    • Bom dia Thamara,

      Acho que assim você resolve seu problema:

      =SE(OU(E3=”aprovado”;E3=”reprovado”);”sim”;”não”) <- FÓRMULA DA CÉLULA D3

      D E
      3 sim aprovado
      4 sim reprovado
      5 não em andamento

      Atenciosamente,

      Gilberto

    • Acho que esta formula pode te ajudar
      =SE(E12=3;”aprovado”;SE(E12=4;”reprovado”;SE(E12=5;”andamento”))) e na outra coluna pode utilizar =SE(OU(F12=”aprovado”;F12=”reprovado”);”sim”;”não”)

  • Boa tarde pessoal!
    Tenho a seguinte fórmula:
    =SE(D4>1000;D4*1,3;SE(D4>500;D4*1,45;SE(D4>100;D4*1,75;SE(D4>1;D4*2))))

    E não está funcionando….
    Alguém pode me ajudar?

    • Bom Dia Willian,

      posso ajudar. Primeiramente notei que seu último SE está sem o terceiro argumento: SE(D4>1;D4*2;”????”).

      Se você puder, por favor, escreva a regra que sua fórmula deveria seguir, ou mande para o email ggomesbrazil@yahoo.com sua planilha com a fórmula, que fica mais fácil de analisar aqui.

      À disposição,

      Gilberto

  • Tenho as duas opções de formula abaixo. Como faço para acrescentar mais nivel, preciso no mínimo 70.
    =SE(E(A1>0;A15;A110;A115;A120;A125;A130;A10)*(A15)*(A110)*(A115)*(A120)*(A125)*(A130)*(A135)*(A1<=40);"BG – ETA"))))))))

    • Bom dia Carlos,

      eu não consegui entender bem a sua pergunta. Você poderia, por favor, explicar a regra que precisa ser atendida? Ou, se possível, enviar junto a própria planilha para eu ver?

      À disposição,

      Gilberto

  • Boa noite.
    Preciso validar uma planilha de recebimento de relatórios diários, onde cada dia (incluindo final de semana e feriados) eu recebo relatórios em horários diferentes, logo gostaria que os horários que eu não receba relatórios seja preenchido com sem envio. Tenho a data numa coluna e cada horário numa coluna também. Detalhe os horários que recebo relatórios tem que ficar em branco para eu preencher se recebi ou não. Será que poderia me ajudar? Obrigada.

  • Alguem pode me ajudar na seguinte fórmula no excel ?
    Exemplo: coluna F3 = Mario e coluna E4=Joao e Coluna G4=500,00
    se F3=mario e se E4=Joao então G4
    Como faço esta fórmula?

  • Alguém pode me ajudar na função SE.
    Preciso colocar 15 itens na função SE e só consigo 8. Ex:= SE(A6=1;RESUMO!$B$5; SE(A6=2;RESUMO!$B$6;SE (A6=3;RESUMO!$B$7; SE(A6=4; RESUMO!$B$8;SE(A6=5; RESUMO!$B$9; SE(A6=6; RESUMO!$B$10; SE(A6=7; RESUMO!$B$11; SE(A6=8; RESUMO!$SB$12)))))))))
    Tem como colocar mais itens. Ex =SE(A6=9;RESUMO!$B$13) até =A6=15????

    • Bom dia Sr. Afonso,

      me parece que a função SE não é a sua melhor opção. O Sr. poderia, se desejar, me mandar seu arquivo ou uma tabela detalhando seu problema para que eu analise qual o melhor caminho.

      Gilberto

  • Olá, por favor, uma ajuda! Alguém sabe se no Excel 2013 eu posso fazer a seguinte operação (e qual a fórmula):
    Se eu escrever alguma coisa (qualquer coisa) na célula A2, a célula B2 fica “trancada”, ou seja, não posso escrever nada.
    Obrigada!

    • Boa tarde Marcela,

      por fórmula não conheço uma forma de resolver seu problema. Via macros, sim, perfeitamente factível.

      Gilberto

  • Prezado. Tenho um probleminha que não consigo resolver. Na célula A1 posso ter várias valores digitáveis.
    Na célula B5 tenho que ter uma fórmula que vai verificar o que foi digitado em A1. Se em A1 for digitado qualquer número até 20, na B5 tem que aparecer o valor 70. Se em A1 tiver um intervalo entre 21 e 50, em B5 deve aparecer o valor 82. E se em A1 tiver qualquer número entre 51 e 100, na B5 tem que aparecer 96.
    Resumindo:
    A1 = 1 ate 20 …… B5 aparece 70
    A1 = entre 21 e 50 …..B5 aparece 82
    A1 = entre 51 e 100 …. B5 aparece 96

    Pode me ajudar?
    Obrigado
    Daniel

    • Bom dia Daniel,

      para resolver sua questão, coloque em B5 a seguinte fórmula:

      =se(a1<=20;70;se(a1<=50;82;96))

      Estou entendendo que não haverá valor acima de 100 em a1.

      Teste aí e me avise, por favor.

      Gilberto

  • Obrigado Gilberto. Funcionou perfeitamente. Show!!!

    • Que boa notícia! Conte comigo!

  • Amigos, tenho um problema, eu queria uma formula que some tudo que esta entre dois dias e horários diferentes (os horários estão digitados em celulas), por exemplo, tenho a coluna A com data, B com horário e C com valor, quero que a coluna some a coluna c, tudo que esteja entre o dia 16/03 após as 23h, até dia 17/03 antes das 11h.

    Poderiam me ajudar por favor?! Obrigada! 🙂

  • Amigos, tenho um problema, eu queria uma formula que some tudo que está entre dois dias e horários diferentes (Os horários estarão digitados em células), por exemplo, Tenho a coluna A com data B com Hora e C com Valor, quero que some a coluna C, tudo que esteja entre o dia 16/03 após as 23h até dia 17/03 antes das 11h.

    Poderiam me ajudar? Tentei o SOMASES mas não ta dando certo!

    Obrigadaa!!!!! 🙂

  • Bom dia Gilberto, estou tentando criar uma formula, porém estou com dificuldades.

    Gostaria de criar uma formula que me desse se a pessoa é super favorável/favorável/neutro/desfavorável, a partir de 4 perguntas, sendo que se:

    1-Sim 2-Sim 3-Sim 4-Sim Super favorável
    1-Sim 2-Sim 3-Sim 4-Não Favoravel
    1-Sim 2-Sim 3-Não 4-Não Neutro
    1-Não 2-Sim 3-Sim 4-Não Neutro
    1-Sim 2-Não 3-Sim 4-Não Neutro
    1-Não 2-Não 3-Não 4-Não Desfavorável
    1-Não 2-Não 3-Sim 4-Não Desfavorável
    1-Não 2-Sim 3-Não 4-Não Desfavorável
    1-Sim 2-Não 3-Não 4-Não Desfavorável
    =IF(AND(AA3=”Sim”;AB3=”Sim”;AC3=”Sim”;AD3=”Sim”);”Advocate”;”Favorável”; IF(AND(AA3=”Sim”;AB3=”Sim”;AC3=”Sim”;AD3=”Não”);”Favorável”;”erro”…..

    porém dá erro, sabe me ajudar nesta hiper formula?

    Um abraço,

    Caio

    • Boa tarde caio,

      Recebi sua dúvida. Responderei ainda hoje.

      Gilberto

    • Prezado Caio,

      enviei para seu e-mail um anexo contendo o exercício que fiz com seu modelo proposto. Em vermelho, estão as coluna onde coloquei fórmulas.

      À disposição e aguardando seu retorno,

      Gilberto

  • Boa tarde., Gilberto.
    Tenho um problema que gostaria de pedir sua ajuda para solucionar.Em uma tabela possuo 4 colunas , na qual a 4ª coluna deve ser o valor médio das outras três.
    Quando coloco a seguinte fórmula =MÉDIA(H15;L15;N15;P15) caso haja algum valor igual a zero, a fórmula inevitavelmente dividirá pelo número de componentes, ou seja 4.Contudo, preciso criar uma condição na qual este resultado fosse a média das células desde que elas fossem diferentes de zero.

    • Bom Dia Sr. Paulo,

      podemos resolver seu problema utilizando uma fórmula matricial. Crie aí a seguinte planilha:

      A1: 1
      B1: 0
      C1: 0
      D1: 1

      Se utilizarmos, em E1, a fórmula =MÉDIA(A1:D1), teremos 0,50 como resposta.

      Porém, se utilizarmos a fórmula matricial = MÉDIA(SE(A1:D1 > 0;A1:D1)) a resposta será, como esperado, 1. Para utilizar a fórmula como sendo matricial, digite-a em E1, conforme acima, e, ao final, CTRL+SHIFT+ENTER. Você poderá notar que a fórmula, depois de registrada, aparecerá entre chaves “{}”, evidenciando ser uma matriz. Assim, o excel dará tratamento matricial à célula E1 e você terá o resultado desejado.

      Teste aí e me diga, por favor, se conseguiu resolver.

      Atenciosamente,

      Gilberto

  • Sr. Gilberto,boa tarde.
    Ao executar essa fórmula terei a média entre os valores que constam nas quatro células divididos por 4…isso é a média,perfeito.
    Contudo, no meu caso, o que preciso é que quando em alguma célula constar o valor zero, a fórmula não contabilize essa célula, ou seja, despreze valores iguais a zero.
    No exemplo criado pelo senhor o valor 1 seria o resultado que eu precisaria, ou seja,…a fórmula deveria somar os valores de A1 e D1 e dividiria por 2, pois os valores que constam nas células B1 e C1 seriam desprezados por serem “zero”, consegui ser um pouco mais claro?
    Desde já, agradeço imensamente toda a atenção dispensada.

    • Boa tarde Sr. Paulo,

      enviei para seu e-mail o exemplo em xlsx.

      Verifique, por favor. Qualquer dificuldade, estou à disposição.

  • Bom dia Sr. Gilberto.

    minha dúvida é bem simples.
    O valor que preciso tornar verdadeiro ou falso está entre um intervalo de valores.
    Exemplo: Preciso comparar meus dados de campo com os dados de campo de um companheiro. Para isso, meus dados tem que estar dentro de um limite percentual de variação adotado para os dados dele (15% para mais ou menos).

  • diariamente emito ordens de serviços para 3 tecnicos que tenho, queria uma planilha onde eu possa lançar estas ordens de serviços e fique acompanhando quando estao sendo devolvidas por cada um deles, diariamente possa cobrar pq o serviço da ordem tal nao foi executada, assim saberei quantas ainda estao na mão de cada um, hoje se me perguntarem o tecnico tal que quantas O.S. em mãos? nao sei responder.

    • Boa tarde Jucileide,

      Para que possamos ajudar melho, como você controla as os’s hoje?

      Gilberto

  • Bom dia Gilberto!
    Estou com 2 problemas na função SE. A primeira situação é que para o funcionário receber um IR de 27% o salario dele tem que ser maior que 3.000, para ele receber um IR de 15% o salario dele tem que ser entre 2.000 e 3.000, como coloco essa opção de ser entre dois números na função?
    A outra situação é parecida, no caso se a media do aluno for maior que 7 e a frequencia maior ou igual a 75 estara aprovado, se a media for menor que 7 ou a frequencia menor que 75 estara de recuperação, caso contrario estara reprovado, como faço essa função?

    • Boa tarde Juciane,

      Entendi suas questões. Ainda hoje mandarei um exemplo pronto, com suas questões resolvidas, diretamente para seu email.

      Atenciosamente,

      GilBerto Gomes

  • Bom dia!!!
    Estou precisando de ajuda com a função SE.
    Problema:
    Coluna A é data.
    Coluna B é Numero nota fiscal.
    Coluna C informa se a Nota fiscal foi cancelada ou não.

    Tem um volume grande de notas fiscais (varias linhas). Entao no final da planilha faço uma planilha resumo.

    Quero indicar se a coluna C estiver a informação de cancelada eu quero que apareca o número da nota fiscal que esta na coluna B.

    Tem como indicar isto?

    Tks

  • Boa tarde, estou com um problema, preciso de uma formula que diga: se tiver algum valor na coluna b1 fazer o procv com a coluna B1 como base, se a coluna b1 estiver vazia, fazer o procv com a coluna c1 como base. Tem como?

    • Boa noite Raiane,

      Sim, é possível. A sintaxe é a abaixo:

      =procv (se (b1=””;c1;b1);e1:f10;2;falso)

      Coloque seu intervalo real no lugar de E1:F10 e também o 2 pelo índice que você precisar.

      À disposição,

      Gilberto Gomes

    • Boa noite Raiane,

      Sim, é possível. A sintaxe é a abaixo:

      =procv (se (b1=””;c1;b1);e1:f10;2;falso)

      Coloque seu intervalo real no lugar de E1:F10 e também o 2 pelo índice que você precisar.

      À disposição,

      Gilberto Gomes

  • Olá,

    Tenho a seguinte função: =SE(G8<=2;"Baixo";"Normal") , gostaria de estabelecer um limite para o "valor normal" e acima desse limite a função considerar "Alto".

    Pode me ajudar?

    • OLÁ FABIO ! COPIE A FORMULA PRA VC, MAS ELA ESTA APARECENDO AQUI NO POSTER APENAS EM PARTE.

  • =SE(E(G82=3);”ALTO”)))

    UTILIZE A FORMULA COMBINADA ACIMA. CONSIDEREI 3 PARA ALTO.

  • VEJA A FORMULA =SE(E(G82=3);”ALTO”))) CONSIDEREI 3 PARA ALTO.

  • Boa tarde,

    Como faço para usar a formula SE, no caso abaixo:
    SE(C4:AN4>180DIAS;”TREINAR”;”TREINADO”); gostaria de saber se nesse caso eu deveria usar alguma outra formula ou se é esta mesmo.

    Aguardo retorno
    Desde de já agradeço.

  • Boa Tarde…
    Precido montar uma planilha de controle de recebimento de relatorio, onde preciso de um controle se ja me foi entregue dentro do prazo de dez dias e a data. Tem como?? já tentei de todas as formas e não consigo. Pode me ajudar?

  • Bom dia

    Estou elaborando uma planilha de dados qualitativos e quantitativos de placas de transito e paradas de onibus. Gostaria de saber qual a função do excell que uso para classificar paradas de onibus em 10 tipos automaticamente, sendo as seguintes

    1 Armação de concreto e telha de amianto
    2 Armação de metal e telha de amianto
    3 Armação e cobertura de metal
    4 Armação e cobertura de concreto
    5 Metal e acrílico
    6 Concreto pré moldado
    7 Armação de Madeira e cobertura de amianto
    8 Armação de metal e telha de zinco
    9 Armação e identificação de metal
    10 Armação de metal e cobertura de fibra,

    de acordo com o número que é colocado na célula de classificação numérica.

    Desde já agradeço

  • Preciso criar uma fórmula do SE:

    se B1 for menor que A1 ATRASO se B1 for maior que A1 EXCESSO.

    Como faço essa fórmula ?

    • Boa tarde Eduardo,

      bem simples: =SE(B1<A1;"ATRASO";"EXCESSO")

  • Boa tarde Gilberto.
    Essa fórmula também seria utilizada para mais de uma condição? Preciso que:
    se Z4 for = 21 e = 30 e = 37 e <=50 seja 10
    Poderia me ajudar? Obrigada.

  • Boa tarde Gilberto.
    O comentário anterior saiu sem os sinais.
    Preciso que:
    se Z4 for menor ou igual a 20 seja igual a 2,5; se Z4 for maior ou igual a 21 e menor ou igual a 29 seja igual a 4; se Z4 for maior ou igual a 30 e menor ou igual a 36 seja igual a 6; se Z4 for maior ou igual a 37 e menor ou igual a 50 seja igual a 10.
    Poderia me ajudar? Obrigada.

    • Posso ajudar sim.

      Identifiquei que você possui 4 possibilidades finais para sua fórmula: 2.5, 4, 6 e 10. Ao fazer a árvore de decisões (anexo em um e-mail que mandei diretamente), vi que, aparentemente, falta uma última hipótese (quando Z4 for superior a 50). Posso assumir que famais será superior a 50? Sendo verdadeira essa afirmativa, segue abaixo a sua fórmula:

      =SE(Z4<=20;2,5;SE(Z4<=29;4;SE(Z4<=36;6;10)))

      Se houver a possibilidade de Z4 ser maior que 50, segue abaixo a outra fórmula, ONDE COLOQUEI 99 PARA ESTE POSSIBILIDADE:

      =SE(Z4<=20;2,5;SE(Z4<=29;4;SE(Z4<=36;6;SE(Z4<=50;10;99))))

      À disposição,

      Gilberto

  • Bom dia,

    Tenho uma planilha com os seguintes itens .:
    Peças importada, peças nacionais, equipamentos e equipamentos importados. Isto porque estou analisando as alíquotas de imposto dos itens.
    A primeira planilha tem todos os produtos e equipamentos vendidos. na segunda temos por estado as aliquotas de icms divididas por colunas onde temos cada estado com sua aliquota.

    Fiz um procv porem ele só pega os dados de uma coluca.

    Como posso fazer para que caso ele for “de SP/ equipamento” ou de ” MT peças ” pegar a aliquota certa?

    Obrigada

    • Boa Tarde Giuliana,

      você pode resolver seu problemas de algumas maneiras diferentes. Abaixo algumas opções:
      FUNÇÃO SOMASES
      PROCV MATRICIAL, COM USO DA FUNÇÃO “ESCOLHER”
      Pesquisas Matriciais, usando a FUNÇÃO DESLOC como apoio.

      Pode parecer meio complexo assim de primeira, mas não é. Se você quiser, por favor, mande um e-mail com uma amostra da sua planilha que analiso e monto um pequeno exemplo aqui pra você.

      Atenciosamente,

      Gilberto Gomes

  • Boa tarde.
    Trabalho com confecção, estou fazendo uma planilha para representantes digitarem seus pedidos.
    Trabalho com Banco de Dados para saber as referências e preços.Consegui fazer, mas se eu digitar uma referência que não está cadastrada, puxa também um valor.
    Queria fazer uma fórmula que avise os representantes que digitaram uma referência errada.
    Podes me ajudar.
    Grato!
    att Valter

    • Boa tarde Sr. Valter,

      exitem diversas maneiras de resolver essa situação. Se o senhor estiver usando PROCV para buscar os dados, utilize o quarto argumento = FALSO; isso impedirá que o Excel retorne valores aproximados, emitindo o erro #N/D caso não encontre. Outra forma seria a utilização de VALIDAÇÃO DE DADOS, especificando uma lista de elementos para o preenchimento da célula, limitando esta lista aos dados cadastrados.

      Para melhor auxiliá-lo, se o senhor quiser, mande uma amostra de sua planilha para meu email que verifico a melhor maneira para o seu caso.

      Atenciosamente,

      Gilberto
      GILBERTO.GOMES@gmail.com

  • Quero ajudar
    SE(A:A=C1838;”x”;0), ela esta dando erro, mais é verdadeira, e se alterar o A:A para A5 ela da certo. O que faço, alguém pode me ajudar.

  • Boa tarde.

    Tenho uma planilha para fazer alguns cálculos de cartões. No meu caso eu recebo de 4 formas diferentes. Á VISTA (Débito), Á VISTA (Crédito) 2x CREDITO, e 3x CREDITO.
    Preciso que ele some as células que forem á vista debito e as outras separadas, e se possível jogar nas planilhas seguintes os valores que vou receber parcelado nas quantidades parceladas, EX R$ 150,00 passei em 3x então daqui 30 dias ou receber 50,00 deduzindo a taxa daqui 60 50,00 e daqui 90 o restante, então Janeiro 50 fevereiro 50 e março 50, mais ou menos assim….

  • Tenho uma dúvida, não é propriamente com o “SE”, este uso perfeitamente em minhas planilhas e me ajuda muito porém, queria fazer o seguinte, por exemplo:

    uma rotina de calculo – faço uma soma simples 2(variavel) + 2 (fixa) = 4
    apertaria um “botão” e o 4 iria para a linha 2 coluna b

    Continuaria faria outro calculo –
    3 + 2 = 5 – apertaria o botao e mandaria o resultado para a linha 3 coluna b

    e assim seguiria fazendo os cálculos

    4 + 2 = 6 e mandaria para a linha 4 coluna b

    Pq disso?! Tenho que dar comissões e isso depende de algumas variáveis, como tenho mais do que 1 variável e estas são imprevisíveis, não há como eu montar uma rotina de cálculos com infinitas linhas, então pensei em fazer minha base de calculo e “jogar” o resultado para uma outra tabela ordenando embaixo e somente depois fazer o calculo, somando toda a coluna.

    Deu para entender?!, você acha que o “SE” poderia me ajudar?! Tem alguma saída?

    • Boa tarde Felipe,

      usando macros, certamente, daria para resolver seu problema. Mas, para tentar simplificar um pouco as coisas, você teria uma “amostra” do seu arquivo que pudesse me enviar? Vendo é mais fácil.

      gilberto.gomes@gmail.com

  • Bom dia, Gilberto.
    Preciso de ajuda quanto a uma situação.

    Devo calcular o IRPF sobre folha e gostaria de saber:
    se o salário estiver entre 1 e 2 = 17%, se estiver entre 2,1 e 3= 18%…os valores são fictícios, mas preciso somente disso.

    Grato.

    • Boa tarde,

      A fórmula fica assim: SE(salario <=1;0;SE(SALÁRIO<=2;17;SE(SALÁRIO<=3;18;99)))

      À disposição,

      Gilberto

    • CARA DA PRA USAR O PROCV SENDO ATIVADO PELA FUNÇÃO NESSE CASO. FICA AUTOMÁTICO!

      voce só vai colocar o valor e se quiser também parcelas ou data p/ pagamento.

  • Boa tarde, muito obrigado. Deus o abençoe!

  • Tenho uma planilha onde tenho campo de porcentagem, data de inicio e fim e status da atividade. Preciso que quando estiver fora da data de termino ela me indique atrasada, quando estiver dentro do período porem não estiver 100% fique escrito andamento e quando estiver 100% fique finalizada.

    • Boa tarde Sérgio,

      sua fórmula, creio, ficará assim:

      =SE(C2=1;”FINALIZADA”;SE(HOJE()<=B2;"ANDAMENTO";"ATRASADA"))
      onde C2=PORCENTAGEM E B2=DATA DE VALIDADE

      Estou enviando, para seu e-mail, um arquivo modelo com a fórmula pronta.

      à disposição,

      Gilberto Gomes

  • Bom dia.
    Fiz a fórmula abaixo cuja somatória das linha 3 a 49 passe a dar o resultado a partir no ponto onde o valor atinja R$2.500,00. Só que esta célula está lincada a outra tabela e é item de outro somatória. Preciso que o resultado do “valor_se_falso” tenha como resultado uma moeda, para que na tabela lincada ele possa realizar a soma.
    grato.
    =SE(SOMA(H3:H49)>2501;SOMA(H3:H49);”2500″)

  • Bom dia,

    preciso fazer uma planilha de validação de dados, para tanto, nosso fornecedor nos cobra por quinzena, preciso fazer uma planilha onde, ex: a quinzena começa dia 01/03, e eu observei que o CNTR “X” entrou dia 25/02 ou seja, ele já me cobrou na quinzena passada, o valor para o CNTR “X” então teremos o valor 0, tenho o CNTR “Y” que entrou dia 02/03/2016 (dentro da quinzena) ou sja teremos que pagar o valor devido 37,00

    ficou claro?

    preciso da ajuda de vcs.

    eu fiz essa formula, porém, esta assumindo o valor fora da quinzena, não sei onde esta o erro.
    =SE(E(F5>=$F$2);PROCV($K$4;’Tabela contrato’!A:B;2;0);0)

    • Boa tarde Julcimar,

      você poderia, por favaor, enviar para GILBERTO.GOMES@GMAIL.COM uma amostra da sua planilha, já com a sua fórmula? Ajudará na análise.

      Obrogado,

      Gilberto

  • pessoal, se alguém tiver interesse em me ajudar, segue e-mail.

    julcimar.quagliotto@jbsfoods.com.br

  • Oi, boa noite. Preciso de uma ajuda. Pode me ajudar?
    Estou precisando fazer q uma célula analise o valor de uma outra celula e então pegue os valores correspondentes numa tabela. Ex: se celula c12 for igual a 1 então ele sera -96% de uma determinada celula.
    Se célula c12 for igual a 2 então o valor sera -93% da determinada celula
    Se célula c12 for igual a 3 então o valor sera -90% da determinada celula e assim ate chegar a 0% como faço?
    Lembrando q em c12 é no máximo 30 (dias)
    Obrigado

    • Bom dia Igor,

      estou encaminhando sua resposta diretamente para o seu e-mail.

      Obrigado e à disposição,

      Gilberto

  • Olá, como uso essa fórmula em que a condição seja haver um valor qualquer na célula? Quando quero indicar que não há, eu simplesmente coloco “”, por exemplo: =SE(D2=””;”Aguardando recebimento”;”Em workflow “).
    Alguém pode enviar a resposta por e-mail? marinamacielel@gmail.com

    • Olá Marina,

      basta negar a sua instrução, assim: =SE(D2 <>””;”Aguardando recebimento”;”Em workflow “)

      À disposição,

      Gilberto

  • OLA, PRECISO DE AJUDA EM UMA FORMULA(Que acredito ser em SE msm)
    preciso que, toda vez que for digitado o texto “LISTA DE PRESENÇA” em uma coluna de uma aba (que ja é preenchida por uma formula em SE), seja COPIADO TODOS OS VALORES DA LINHA EM QUE CONSTA ESSA INFORMAÇAO para outra aba na mesma planilha.
    porem o problema e que eu nao sei o comando usado para copiar essas informações, e preciso muito disso.

    se alguem puder me ajudar, ficarei grato.

    att,

    Marcus Souza

    • Boa noite Marcus,

      pelo que imagino seRa preciso escrever uma macro para isso. Por acaso vc teria como me mandar seu arquivo para eu ver melhor? Se sim, Gilberto.gomes@gmail.com

  • Gilberto boa tarde, vc poderia me ajudar com uma questão talvez simples para vc mas meio complicada para mim, existe alguma formula que eu possa aplicar em um campeonato de futebol, ex: baseando que cada vitoria 3 pts empate 1 e a derrota naturalmente não some ponto algum caso vc possa me ajudar com o problema fico no aguardo e gostaria que vc me respondesse se responder é claro no meu e mail.

  • Hi. Only wanted to ask a quick issue. Now i am ebbbeadaadeb

  • AJUDOU MUITO

  • Olá preciso de um fórmula que calcule entre intervalo de valores e retorne com o texto : Ganhou xxx pontos
    Exemplo compras acima de R$ 1.000 ganhou 200 pontos .

    Estou perdidinhaaaa …

    Estou tentando a fórmula Se , mas está dando erro.
    ( =SE(G20>=K12<K13;L12;"NÃO GANHOU PONTOS ")

    Compras Acima de
    de R$ 1.000,00 GANHOU 200 Pontos
    de R$ 2.000,00 GANHOU 600 Pontos
    de R$ 3.000,00 GANHOU 1.200 Pontos
    de R$ 4.000,00 GANHOU 2.000 pontos

    Alguém pode me ajudar ?

  • Boa tarde,
    tenho algumas linhas com nomes de pessoas repetidas ou nao, e em coluna tenho alguns valores.
    Preciso de uma formula para somente me fornecer um Nome (quando repitido) e o maior valor, nao somatório, somente o valor maior.

  • Adorei o conteúdo, é incrível quantas informações ricas que encontro aqui. Eu tinha algumas dúvidas mas agora solucionei tuuudo.

  • Preciso de separar as horas extras, por exemplo tenho 4 horas extras com a jornada de 20:00 ás 6:00, portanto, tenho 2horas diurnas, 8 noturnas já reduzidas e 2 horas diurnas ao final do turno, como separar estas horas se eu preciso identificar que no máximo até 2 horas 50%, as demais h. e. noturnas também são 2:00. e aí como montar a formula.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Autores

Pesquisar:

Siga-nos!

Patrocínio

Facebook

Facebook By Weblizar Powered By Weblizar

Inscreva-se em nossa Newsletter